Documentation

VNC Proxy Server (HTML5)

Download (pdf)

Install

# yum install -y  hubzero-vncproxyd-ws

Configure

Package hubzero-vncproxyd-ws version 2.1.3-1 or greater is required

Package hubzero-mw-client version 2.1.1-1 or greater is required

# hzvncproxyd-ws-config configure --enable

The configuration process will try to autodiscover what SSL certificate to use. If you have a custom SSL certificate you can either specify it on the command line (the files must be readable by user 'hzvncproxy'):

# hzvncproxyd-ws-config configure --enable --ssl-cert  --ssl-key 

or you can copy them to files /etc/hzvncproxyd-ws/ssl-cert-hzvncproxyd-ws.pem and /etc/hzvncproxyd-ws/ssl-cert-hzvncproxyd-ws.key and make sure they are readable by the user "hzvncproxy" and they will be found automatically.

If you are using a self-signed or otherwise invalid certificate the tool viewer will likely reject it and not work. If you are using the same certificate as your website and you allowed Chrome to use the invalid cert then the tool viewer will probably accept it. If you are using Firefox the tool viewer will always reject the invalid certificate. Always use a valid SSL certificate with hzvncproxyd-ws.

Last modified: